• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

2 problems after assembly

#1 physek
Hi guys,

I just would like to thank you for awesome guides, i just finished my assembly of Intervalometer. Everything is working fine, except two little problems:

1. With USB power supply, display works just fine. With my 9V battery connected, i can see just boxes around text and the text itself, its unreadable. I just found, that i can see the text by looking from a different angle.

2. When I plug Intervalometer into my camera (Canon 200D), it immediately release the shutter and from that point, im unable to change anything in my camera. Intervalometer works just fine, releasing shutter in time, but before timelapse, im unable to change settings etc.

I know, there is a thread about my 2. but i would like to know, if there is another solution. Im not sure about just the halfway plug. I dont want to risk the release during my timelapse.

Thank you very much, i hope, u can solve my problems Smile
#2 niko_at
Hi, its difficult to help you with the poor information you gave to us.

ad 1, Problem in powersupply . cable, circuit etc.
Need diagram and photo of your assembly.

ad 2, Diagram, transistor or optocoppler or direct arduino output.
#3 physek
Thanks for feedback, i will upload my photos tonight. I would like to solve problem 2 with priority, because im gonna use External power bank as a power supply so i dont mind this problem with battery, but i would like to know, where is the problem Smile Problem 2 is also minor problem, because i can preset my camera first and after setting everything properly, plug in the Intervalometer, but its kind of anoying.
#4 Sheeba
Hi physek,
to 1.
a USB power supply delivers less than 5V. If you supply the UNO with 9V the internal voltage is 5V. This small difference can affect the display as you describe. You only need to adjust the contrast on the display at 9V. This is done with the potentiometer in the upper left corner of the display.
to 2.
A trigger when connecting the camera to the PT can not be prevented. It is best to turn on the camera after it is connected to the PT.
If you can no longer operate the camera once it is connected to the PT, it is most likely because the focus is permanently switched. You can easily check that:
When the shutter button on the camera is pressed halfway (focus only), you can see it somewhere on the camera's display. If you have the same display as soon as the camera is connected to the PT, the focus is permanently switched on and you need to re-check your wiring.
Maybe I'll see the mistake, in your pictures.
Regards, Hans
#5 physek
Thank you Hans,

You are very kind Smile I will upload it at 18:30 and i will let you know how it works with the focus problem. I did everything as you mentioned in your assembly guide, so i dont know, how should be focus permanently triggered. Hope my photos will help you to solve it Smile
#6 Sheeba
.. please also provide me the Version of the Software you are currently using!!
#7 physek
Hi Hans,

I'm running 0.93/4 software version. The problem is still the same, even with intervalometer pluged in before camera is turned on. Here is my setup : https://linksharing.samsungcloud.com/154...853C8cgpxo

Thank you very much. Really would like to solve this Sad
#8 Sheeba
Hi physek,
your wiring looks ok. So you use the option "internal transistors"
did you do the setting for Camera 1 in the sketch as follows?
Line 123
// Camera 1 setings
// # define Cam1_ext_HW
#define Cam1_int_HW
Or do you have a measuring device? If so, please measure the voltage at the focus pin. The should be about 5V synonymous if
the camera is connected. If not measure without camera connected.
What happens if you only connect the trigger cable to the camera? So not connected to the PT.
Can you then operate the camera? (Maybe a bug in the cable)
Check this and answer, then we'll see.
Regards, Hans
#9 physek
Hi Hans,

I will try your advices, but first, check this: I tried to connect cable connected to the Intervalometer (turned off, with no access to power suply - usb not connected and battery disconnected) and i got the same problem. When i connect just cable (not connected with Intervalometer) everything is ok.
#10 physek
OK, so i tried your solution with code. When i changed that settings, problem is gone, but there is another one. Intervalometer is not working properly. In my first test, it just released shutter for the first foto. In second case, first three photos. When i swiched it back to

// Camera 1 setings
# define Cam1_ext_HW
//#define Cam1_int_HW

Shutter release works just fine, but im unable to operate my camera Sad

...also check out: