• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Auto Transition Gap

Offline
#1 kneverett
I'm working on a very straight forward time lapse sequence with 751 images in DNG format loaded via Lightroom. The initial preview had minor variations in Lum values until about 75% through the sequence. Then there was a brief peak followed by a dip and then back to about the same level as the first half. The peak and valley aren't wild swings though.

Using the wizard I created 5 key frames. There were a few, perhaps 10-15, ISO changes I made during recording. So I used the Holy Grail wizard to smooth that and then saved the meta data. I used very minor slider adjustments with the Holy Grail sliders.

In Lightroom I adjusted the key frames and used the script to copy forward the changes progressively. I did use both of the radial filters and one of the gradient filters. I did not make any changes in crop. Visually in Lightroom, the exposures were relatively close. Certainly no wild shifts.

When I used Reload in LRTimeLapse, there was a gap of about 10-12 frames where the Lum values were actually lower than the initial Preview Lum values. Although all my adjustments in Lightroom were to brighten all five key frames to various degrees. When first loaded, the initial preview frames were all brighter than what you would see in Lightroom with zero adjustments, I assume this is an "auto" JPEG conversion thing. For the frames which make up the gap, it appears as if they reflect the exposure level of the raw file with no "auto" JPEG adjustment. Much darker than before the Reload.

The gap occurred a dozen more more frames past the first key frame, and well before the second key frame. I've tried several different things to "fill the gap", but each time the gap simply moves - appearing earlier or later in the sequence. The number of frames in the gap also varies as different attempts were made. I tried:

- simply re-execute the Reload
- resetting the meta data
- clearing the meta data
- reloading the exif data
- removing the .lrt folder and all the xmp files

Any thoughts on this? I saw in another post someone had some what similar issues with Visual Previews and it seemed the deflicker step either corrected or mitigated the issue. Although I've not tried moving on to that step.

Thanks!
Offline
#2 kneverett
Okay, I thought I had finally gotten a clean run. But....

I started over completely. Zapped all the folders and files from both Lightroom and LRTimeLapse, then imported the images into Lightroom again. After editing key frames and reloading I started the Visual Previews build. It got well past the second key frame working as designed, much further than on prior attempts. As it was creating the previews and building the purple curve I scrolled down to where it was leapfrogging forward then back filling. I selected one of the frames in that area to view it. Ones near it had been skipped over, so I expected it to come back to them and back fill as it had been doing. But it kept moving forward without coming back to fill the gap.

Baffled, I decided to use the Refresh Previews (Ctrl-F5) and re-export the meta data from Lightroom for yet another attempt. This time, rather than just save the key frame meta data to files, I selected all images in the sequence and forced them all to get written. Back in LRTimeLapse the preview play head was at the very start. I did a Reload, Auto Transition and started the Visual Previews. This time I touched nothing while it was working. I did scroll down and view, but never selected a row of data. Viola, it went all the way to the end. And there were no gaps. It worked (seemingly). I played the preview. Seemed good. I reached a point where there are a few frames with brighter exposure due to the natural light increasing. I scrubbed the play head back and forth a bit and stopped on one of the brighter frames. Noting the file name and position number, I switched over to Lightroom to view the images and a few near it.

After a minute or two I came back to LRTimeLapse. It had eaten a block of previews just prior to and following the selected frame. It actually munched on a couple of frames as I watched before it finally stopped. I had selected frame 514, it cleared previews all the way back to 484 and all the way forward to 530.
Offline
#3 gwegner
Sorry, it's very hard for me to follow, what you are doing, what happened and what you expected to happen.

Are you using JPGs converter to DNG or are those native (Raw) DNGs?
If you convert JPGs to DNG, you need to make sure that they have no Lightroom edits on them, before converting, because otherwise the develops will be altering the "camera previews".

If you suspect a general problem it might be good to work with native Raw Files or Raw DNGs. Try also another sequence. Do you get the same results?

Next: I'd like to know which version of LRT you are using?
Do you get any errors in the log file after your anomalies occur? (Please send the log file).

Also I would like to see some screenshots of what you are experiencing or even better a screencast video.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#4 kneverett
I had a "clean" run through the Visual Previews at the end of the day yesterday. So I started the Visual Deflicker to let it run over night. I used a smoothing value of around 30 and did a multi pass with 2 passes. When I checked this morning the Deflicker is done, but again I've got "skips" of approaching 200 frames where the Lum values are way off.

I'm using version 5.2.2 of LRTimeLapse and the most recent version of Lightroom Classic CC.

I shot the time lapse in Raw only on a Sony a7Rii. When I imported the files into Lightroom I have it convert the ARW files to DNG. My default settings for the LR import are to build smart previews and build 1:1 previews. I don't apply any develop or metadata presets on import, but I do apply some key words.

How is it best to send a video? I sent the logs and a few screenshots via e-mail.
Offline
#5 kneverett
To let you know, you're suggestion in your e-mail to check the Lightroom setting for "automatically write changes to XMP" was on the mark. I recently migrated to a new PC and on the old computer I had it off. By default this appears to be on. That explains why it was working for my earlier time lapses but not this most recent one. BTW, this setting is catalog specific. Now that I am aware of the need to have it off, I'm considering creating a catalog specific to time lapses. Then I can have it ON for my normal photo images and OFF for time lapses.
Offline
#6 gwegner
Glad you found the problem. Just my two cents to leave that setting on for other purposes: I'd leave this setting always off. It's a performance killer. And if you ever need XMP files (apart from LRT) it's just a Keystroke to let LR write them on demand (Ctrl/Cmd S).
Also a separate catalog for Timelapse will prevent you working on your other images while your are waiting for a timelapse to process.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#7 kneverett
Thanks for the follow up. Sounds like good advice.

...also check out: