• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Lightroom option "Automatically write changes into XMP"

Offline
#1 gwegner
Wouldn't the activation of the Option "Automatically write changes into XMP" in the Lightroom Catalog Settings make the workflows easier?

No! Please don't activate that! It might cause a lot of trouble, sometimes subtile and hard to find the cause for, when used with the LRTimelapse/Lightroom workflow.

The LRTimelapse workflows rely on LRTimelapse initializing the XMP data properly and keeping it consistent. If Lighroom eventually writes things on it's own the experiences show that this messes things up. So please, always leave this option off and follow the Workflow, you will quilckly get used to Read-/Write Metadata when it's needed, this makes the whole behavior much more predictable.

[Image: https://dl.dropboxusercontent.com/u/2088...tadata.png]
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#2 Fabienne
(2013-08-12, 14:58)gwegner Wrote: Wouldn't the activation of the Option "Automatically write changes into XMP" in the Lightroom Catalog Settings make the workflows easier?

No! Please don't activate that! It might cause a lot of trouble, sometimes subtile and hard to find the cause for, when used with the LRTimelapse/Lightroom workflow.

The LRTimelapse workflows rely on LRTimelapse initializing the XMP data properly and keeping it consistent. If Lighroom eventually writes things on it's own the experiences show that this messes things up. So please, always leave this option off and follow the Workflow, you will quilckly get used to Read-/Write Metadata when it's needed, this makes the whole behavior much more predictable.

[Image: https://dl.dropboxusercontent.com/u/2088...tadata.png]

Could this option be a solution in case I work with jpeg? My problem is that I don't get any xmp data into LRT 3.
Offline
#3 gwegner
No, for JPGs you won't see the XMP files, the XMP data will get written into the JPG files.
Please don't turn this option on for JPGs either.

Please try to follow the workflow like I showed it in the tutorials, this works for JPGs exactly as for RAW files.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#4 Fabienne
(2013-10-07, 13:21)gwegner Wrote: No, for JPGs you won't see the XMP files, the XMP data will get written into the JPG files.
Please don't turn this option on for JPGs either.

Please try to follow the workflow like I showed it in the tutorials, this works for JPGs exactly as for RAW files.

Well, I tried, but it didn't work. I can mark the keyframes in LRT, save and then also edit them in Lightroom. There it's also possible to save and back in LRT, I can click on reload, and it also seems to reload the metadata for the keyframes, but the components just don't change.

Greetings
Fabienne
Offline
#5 gwegner
This is strange. Have you checked these tips: http://forum.lrtimelapse.com/Thread-meta...ng-applied
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#6 Fabienne
(2013-10-08, 23:46)gwegner Wrote: This is strange. Have you checked these tips: http://forum.lrtimelapse.com/Thread-meta...ng-applied

Yes, I considered all of your tips in the very first post and went through the others - but it doesn't seem to be the same problem. It's not the "futurgate problem", in the filenames are no spaces and with RAW files, everything works perfectly. This problem just appears when I'm trying to work with JPEG files... I changed things in the exposure to make sure that it's not just because some colourchanges aren't visible.

After clicking reload, LRT says it's reloading the xmp data and it also says that the exposure is being adjusted, but everythings remains the same.

I'm using LRT3.1 and LR5, if this is somehow helpful to you.

Greetings
Fabienne
Offline
#7 Fabienne
(2013-10-10, 10:51)Fabienne Wrote:
(2013-10-08, 23:46)gwegner Wrote: This is strange. Have you checked these tips: http://forum.lrtimelapse.com/Thread-meta...ng-applied

Yes, I considered all of your tips in the very first post and went through the others - but it doesn't seem to be the same problem. It's not the "futurgate problem", in the filenames are no spaces and with RAW files, everything works perfectly. This problem just appears when I'm trying to work with JPEG files... I changed things in the exposure to make sure that it's not just because some colourchanges aren't visible.

After clicking reload, LRT says it's reloading the xmp data and it also says that the exposure is being adjusted, but everythings remains the same.

I'm using LRT3.1 and LR5, if this is somehow helpful to you.

Greetings
Fabienne

It finally worked! I'm not quite sure why, I changed the mamory location of the images, maybe this had an influence.

Greetings
Fabienne
Offline
#8 gwegner
Glad it's working now, strange problem indeed.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo

...also check out: