• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

LR Exporter - "temp" folder / file-naming issue

Offline
#1 martinheck
There seems to be an issue when exporting multiple sequences from LR with the LRT exporter:
Folders marked, frames from those folders also all marked, then just exporting to tiff with the LRT exporter (no "overwrite, skip etc". chosen. Just "skip rendering in LRT" marked)

If it happens that some of the sequences have been shot at the same time (but with different cameras obviously) the sorting naturally isn't in sequential order anymore since its sorted by capture date. So shots from different folders/sequences are interleaving in the overall selection for export.
Once the exports process gets to those pictures, it writes those frames to a temp folder on C: (C:\Users\martin\AppData\Local\Temp\E5F5DF84-AB04-4200-A18F-E064836DBDDE). Obviously the C: disk gets full in no time and the export will stop.
Maybe this happens due to another issue. I'm not 100% sure. It just starts writing to the temp folder at some point.

Trying to resume the export with the "skip existing images" option ends up in the same way. The photos in there have the frame numbers from the selection in LR (if you have 6000 frames from 4 folders for example it will just number them LRT_00001-06000.tiff), not the "correct" frame numbers from each folder/sequence.
All those end up in the temp folder as well.

If you try to resume a single sequence instead it will start rendering from the beginning. But instead of not rendering existing files it renders those anyway and writes them to the temp folder where they stay. This has the same effect as just rendering from start again since its actually renders even existing files. Frames that do not exist yet get written normaly as they should.
Timestorm Films | Professional Timelapse Photography
www.timestormfilms.com
YOUTUBE

Online
#2 gwegner
It's hard for me to reproduce this due to many aspects being mixed in that scenario:
- multiple camera with same timestamp
- harddrive running full etc.
Maybe you could try to narrow down the issue with these explanations:

Since Lightroom do not natively support the export to multiple destination folders, the LRTExport plugin needs to work around this. Therefore it exports to one folder first (temp folder), remembers which file will need to get into which folder and which name it needs to get and then passes the whole export task to Lightroom.
Lightroom then exports the whole export task containing multiple sequences with subsequent numbers, which do not necessarily correspond to the final filenames.
After each exported image, the exporter will rename and move that single file to its final destination.

This means, normally the temp folder should not run full, since there shouldn't be more then a couple of images (due to Lightrooms multitasking) inside the temp folder before they are moved by the LRTExport plugin.

Of course, if the harddrive with the temp folder still runs full, the export will fail.

I hope this information helps to narrow down what's going on in your case. The LRTExport log in your Documents folder might also be of help since it documents pretty well what's happening during an export.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo

...also check out: