• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Photos goes to wrong order

Offline
#1 Markus Kiili
I have a big problem with LRTimelapse 4,3 Pro. Photos does not come to video in correct order. The file names and times are ok in Lightroom, but when I try to make a time-lapse, LRTimelapse seams to put them in what ever order and it change also filenames and times. Just a moment ago photos were first in correct order, but after keyframe adjust and hitting Reload photos were in totally  wrong order. This is frustrating.
Offline
#2 gwegner
Please check the order first in LRTimelapse: after loading, LRTimelapse will load the exif data for the images and sort by Date-Time rather then Filename (you can toggle this with the checkbox above the table "Sort by Filename", but normally this should be off!

If you files have correct exif-timestamps, the sorting will be right here.

Then bring the sequence into Lightroom - bring up the toolbar (T), make sure to have chosen Sort: "Capture Time" here.

Now export via LRTExport - you should now have the right order!
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#3 Markus Kiili
I thought so too, but LRTimelapse change filenames and time by it self. If I take a filename of one of those misplaced photos in LRTimelapse and find it from Lightroom, it's a different photo. I think that there is a bug in program. Am I only one with this problem?
Offline
#4 Markus Kiili
First I thought that there is something wrong in my camera, but after going thru frame by frame in Lightroom I noticed that they are there correctly and wrong filenames and times are LRTimelapse problem.
Offline
#5 Markus Kiili
Weird thing is that most of times order is correct. This problem has been appeared if I have over 400 photos.
Offline
#6 Markus Kiili
I did some testing. If I take same photos but use one time for example 150 photos, everything goes fine. But if there is 600 or 800 photos, LRTimelapse mess the photos.
Offline
#7 seawildearth
So in Lightoom when you import them select Sort by Capture Time. Problem solved...
"A man is only as big as the dreams he dares to live"
Offline
#8 gwegner
LRTimelapse certainly does not change any filenames if you don't ask it to do.
The only way thay LRTimelapse could change filenames would be, if you use the LRTimelapse importer and check the option to rename the files. Then it would prefix Date/Time to the filename - but again, those timestamps will be the timestamps from the exif data in your files. As long as this is correct, you will have the naming in the right order too.

But as I already said - normally, the filenames are not being considered at all - LRTimelapse and Lightroom will by default use only the Exif-Data for sorting. So I assume something is wrong with the exif data of your files.

Maybe you could send some screenshots of the table in LRTimelapse showing the position where you think the sorting is wrong.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#9 Markus Kiili
Problem solved.

First I had in Lightroom sort by filename on and then problem appeared. I changed it to sort by capture time and nothing happened. Then I copied photos to different folder with a different folder name and tried again. Then everything worked ok.

Something odd there is anyway. When photos first were in Lightroom sorted by name, were filenames in LRTimelapse in correct order, only photos were not. Filenames had a running number so it was easy to check. In Lightroom photos were in same order in sort by capture time and sort by name, because name was running number. I still think, that there is smoking of bug, but now when I know that I change sort by capture time, even if order is same as by file name, before loading it to LRTimelapse, I can work fine.

...also check out: