• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Ratio of 16:9 is changing to 3:2 during import

Offline
#1 Richard
Hello,

I am shooting timelapses with a Sony A7II at a ratio of 16:9. The size of the RAW- and JPG-images is 6000x3376. After I've imported the RAWs with LRTimelapse 5.0.7 the image size has been changed to 6048x4042. So the image-ratio has been stretched to 3:2 automatically. This doesn't happen when I'm importing the JPGs (but of course I want to use the RAWs for creating my sequences). I could use a crop of 16:9 while editing the keyframes in Lightroom or even force a 16:9-result in LRTimelapse before rendering the video but this only cuts off a bar at the top and bottom of the streched images. The result is still stretched.

Can that issue be solved by changing the LRT-preferences? Propably I could solve the problem by shooting timelapses in 3:2 and cropping the keyframes afterwards to 16:9. But this workaround is not suitable for the sequences I've already taken Wink

It seems like mig13 had the same issue:
https://forum.lrtimelapse.com/Thread-vid...ot-so-much

Kind regards
Richard
Offline
#2 gwegner
Hi Richard,
when you change the AR in Camera, it will capture the full image in RAW and only set a marker for the crop. Some software will evaluate that marker, some not. It's not a good idea to let the camera do the cropping, since all kind of weird stuff (like messed up aspect ratio) can happen.

Here is how to remove the crop from your images (I hope this works for Sony also, it did work for Canon).

Start by making a backup of your image folder. Remove the folder from Lightroom, if it's in the library.
In LRTimelapse right click on the folder (while not loaded) and select "Clear all LRTimelapse editing"

Open a terminal window on your mac or Commandline on PC.

type "cd " (trailing space but no quotes) -> now drag the folder with your images into the terminal. You should see:
cd followed by the path to your images. Hit enter.

now paste this line into the terminal: (change the sizes parameters to the original Dimensions of your images, which in your case would be 6048 and 4042, change the File extension also to match your files, for Canon it's *.CR2, for Sony *.ARW etc.)

Code:
exiftool *.CR2 -CroppedImageWidth=6048 -AspectRatio="3:2" -croppedImageLeft=0 -ImageWidth="6048" -ImageHeight="4042" -DefaultCropSize="5760 3840" -DefaultCropOrigin="0 0" -overwrite_original

(on windows you might have to provide the full path to exiftool which is: C:\Program Files\LRTimelapse 5\exiftool.exe at the beginning of the line)

Now drag the folder to Lightroom, to check, if the crop has been removed. If so, remove the folder again from the Lightroom Catalog and start the LRTimelapse workflow.

I hope, I could help. Next time shoot without the crop set. It's more flexible to crop in post - especially since you will be capturing and storing the whole image anyway.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#3 Richard
Hi Gunther,

many thanks for the quick reply, I really appreciate that! I didn't knew the whole image will be stored no matter which aspect ratio I've chosen. I understood  your workaround (except the exiftool-code in detail) but for some reason the command prompt of Windows is answering "No matching files" after changing the directory and pasting following code:

Code:
"C:\Program Files\LRTimelapse 5\exiftool.exe" *.CR2 -CroppedImageWidth=6048 -AspectRatio="3:2" -croppedImageLeft=0 -ImageWidth="6048" -ImageHeight="4042" -DefaultCropSize="5760 3840" -DefaultCropOrigin="0 0" -overwrite_original

I've also tried to change  the width and the height in the code because the camera creates 6000x4000 at 3:2 and 6000x3376 pixels at the 16:9-setting but it does not solve the problem. After running the code Lightroom still shows the cropped images with an AR of 16:9.
Offline
#4 gwegner
Yeah, in your case it's not "*.CR2", it's rather "*.ARW" for Sony, I guess. This is the extension of the files.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#5 Richard
I've tried this on new images in a new folder which has not been imported to Lightroom before. Propably there is no issue with the code because the command prompt is showing now "100  image files updated". After the import Lightroom sadly still knows about the 16:9-crop. Maybe it is not working for Sony cameras.

Do you have got another advice for me? However - I've just  changed my memory recall mode for timelapses back to 3:2 Big Grin
Offline
#6 gwegner
I'm sorry, with other cameras that worked. If you want, send me one of those images and I'll have a look. No promises however...
Send it via https://fromsmash.com/ to support(at)lrtimelapse(dot)com
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#7 Richard
Hi Gunther,

this would be great! Smile I've sent a random RAW-file to you. Good lock Big Grin
Offline
#8 gwegner
As far as I can see, you can just remove the crop when editing the keyframes in Lightroom: go to the crop tool ® choose "Original" as aspect. In LRTimelapse you might get a wrong aspect ratio (strached vertically) for the camera previews (visual previews not activated) but when you activate the visual previews, you'll get the right aspect ratio in 3:2 then and the full frame.
I recommend to do the cropping to 16:9 when rendering (in the render dialog).
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#9 Richard
Hello Gunther,

well... this feels bad. I was wrong all the time! After drag&drop the images from LRTimelapse to Lightroom it is ignoring the crop of 16:9 of my camera and shows the whole image with the AR of 3:2 (not stretched!). So the crop tool of Lightroom is already set to "Original". What you are saying is completely right: After editing the keyframes LRTimelapse is showing a streched camera preview  until I activate the visual previews. Later Lightroom is exporting my sequence in  3:2 and I just have to force an 16:9 output before rendering the video. I'm sorry for wasting your time but thanks a lot for helping me out! I guess the fact a 16:9-image still can be converted back to it's original aspect ratio of 3:2 and the streched preview in LRTimelapse were confusing me.

Have a nice evening!
Offline
#10 gwegner
I'm glad we could sort that out!
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo

...also check out: