• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Weird behaviour of automatic/batch multi pass deflicker vs. manual deflicker

Offline
#1 lightatwork
Hi Gunther,

Thanks once again for creating such a nice product. The batch features in the latest version 5 are saving me a ton of time, so the wife and kids send their gratitude as well... ;-)

Reason for posting is that I see some issues when using the "Multi Pass Deflicker" option in the Batch Processing menu (when using the right mouse button on a sequence in the folder tree).

Let's say I have a sequence with some (but not extreme) amount of flicker. When I press the Make Visual Preview button in the regular workflow, let it run an finish making the visual previews, and then apply visual deflicker from the regular workflow menu, I get a nice and almost completely smooth sequence.

When I take that same sequence and use the automatic "Multi Pass Deflicker", the result is far worse. Still lots of flicker. To make matters even worse, once it ran through the automatic/batch deflicker actions, I am not able to get the sequence smooth again, using one more manual deflicker pass. In short, once it is bad, it stays bad. The only option is to initialise (trash) the deflicker column and start all over with the visual preview/deflicker process. So you understand that the (in theory extremely nice) option of having a number of sequences batch processed is not usable for me.

I can set up a comparison for you to show you what I mean, but first I wanted to check with you what you would like to see specifically, so I can give you the best/right information.

Thanks for keeping up the good work and hope we can figure this out.

Regards, Jorrit
Offline
#2 gwegner
Normally you wouldn't apply deflicker directly via batch on a sequence before prior editing, since deflicker wouldn't then take into account any keyframe-edits. The normal workflow with LRT Pro would be to go though the sequence, do the keyframe editing, start the visual preview creation and then instantly move on to the next sequence. Once you switch to the next sequence, you will get asked, if you want to continue creating the Visual Previews in Background, say yes here and tick "Add automatic Multipass Deflicker". This will raise another dialog where you can set the deflicker settings. LRTimelapse will then do the deflicker in batch while you are working on the next sequence.
Check out my advanced tutorial where I show those processes. It's the last tutorial on https://lrtimelapse.com/tutorial/
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#3 lightatwork
Hi Gunther,

Thanks for getting back to me so quickly.

First of all, sorry for not being clear with regard to my workflow. As you suggest in your first sentence, (of course) I first complete the entire first row of editing steps in the visual workflow and the first two of the second row. So all keyframing, saving, editing keyframes in LR, reloading and applying auto transition is done (succesfully), before I come to my original question.

Second, I understand your proposed workflow of (after editing keyframes in LR and applying auto transitions) selecting the sequence, pressing the Visuals Previews button, skipping to the next sequence and using the pop-up window to select the type of visual deflickering. I will use that method from now on.

However, it is not clear to me when I can or should use the two options ("Generate Visuals Previews" and "Multi Pass Deflicker") given in the "right-click menu". Just to be sure I attached a screenshot pointing out the two options. I've quickly checked the tutorial video's (sorry if I missed it), but can't seem to find a specific instruction on these two options.
My assumption was that "Generate Visual Previews" would do the same as selecting the sequence and pressing the "Visuals Previews" button in the workflow and that "Multi Pass Deflicker" would do the same as:
- Make sure Visual Previews are generated and if not, generate visual previews
- Apply Multi Pass Deflicker in the same way the pop-up window (we mentioned above) would do when clicking away from a sequence while visual previews are being created.

Probably my assumptions are incorrect. Could you please specify if/when I could/should use these two right-click-options?

Many thanks again!

Regards,

Jorrit
Attached Files
Thumbnail(s)
   
Offline
#4 gwegner
Yes, normally those options should behave the same way. I will check, if there's any difference, I will move this thread to bug reports and do some experiments, if there is any unexpected behavior when using the right click menu. Until then, please just proceed as I explained.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#5 gwegner
You are right, there was an issue with the batch multipass deflicker, it was weaker then the regular multipass deflicker. This will be fixed in LRTimelapse 5.1.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#6 lightatwork
Happy to have helped to find and solve it. Looking forward to LRTimelapse 5.1.
Offline
#7 gwegner
It's up for download now. Let me know your feedback!
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#8 aksel.gresvig
I actually think I reproduced this bug with the latest LRT

Scenario: I have a number of sequences, editing finished in LR. In LRT I select one folder (lets call it sequence A), then click "Visual Previews" and after a few seconds I move to another folder (sequence B). As expected, I am prompted to also add automatic deflickering. I choose to do so, with two passes. I just let LRT sit idle in the folder for sequence B, allowing the "background deflicker" to finish.

Expected results: Sequence A gets a smooth luminance curve after having two passes of deflickering run.
Actual result: Sequence A still has a lot of flickering, and lum. curve does not look deflickered.

If I go to sequence A again, then hit the "Visual deflicker" button and refine again, I get a much smoother lum curve and the sequence is deflickered just as expected.

Attached are two screenshots: One of LRT showing the sequence with lum curve after the "move to next folder" deflicker. The other screenshot is the same sequence and lum curve after using "normal workflow" deflicker. You can see a clear difference in variance in the lum curve

System specs:
iMac with MacOS Mojave
LRT 5.1.1 build 570
Adobe DNG 11.1.0.112
Sony ARW files

Another, perhaps related "batch processing" bug:
I ran batch-generate visualize previews on a folder, which seemed to run successfully since it hogged my system resources for a long time, and added the visual preview indicator to each sequence. However, as I subsequently open these folders in LRT, the vis. prevs. seems to immediately get "lost" - they are not there, and the vis. prev. indicator disappears. Pls. see demonstration: http://recordit.co/iLwZbrgSRu
Attached Files
Thumbnail(s)
       
Offline
#9 gwegner
I cannot reproduce either of the problems here, but they might be related on your system.
lets start with the second one: the visual previews will only be discarded, if the XMP files are younger then the generated preview files. In that case LRTimelapse regenerates them.
A reason for that could for example be another program updating the XMP files in background (for example Lightroom, if you have set the option to "Automatically save changes to XMP". This must be turned off! It might also be a problem with the date/time setting of your computer.
Please try and double check the visual preview generation in batch, like you did and see if you can find the reason why the XMP files get altered and discarded. As long as this doesn't work, the batch deglicker won't also, because it will be losing the XMP files all the time.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo

...also check out: