LRTimelapse Forum

Full Version: Strange result with Holy Grail - only works on part of the shot
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Happy New Year Gunther!

After successfully using LRtimelapse for years, I'm having an anomaly with a shot.

Shooting a day/night transition like I've done hundreds of times before, using the Holy Grail workflow as I change the exposure duration as the scene gets darker.

Oddly, I'm getting some severe stair stepping of my exposure early in the shot as I changed exposure, but later the HG does its thing correctly. I'm including screen shots of the Before/After to show you the problem.

This is from my first series of shots with a Nikon Z7 and version 5.1.1 of LRtl, so I don't know if either of these new variables bears any responsibility.

-Mike Curtis
...and here's the column data that goes with the shot:
I zeroed out the exposure compensation on frame 19 trying to fix is why it is different
For me everything looks normal. You have a shot, which gets very dark (visible on the blue luminance curve). That means when shooting you did not do suficcient compensation in order to get properly exposed images. The Holy Grail wizard does the best it can to compensate for the jumps, but still, the sequence will be dark at the end. If you want to work against this, use the regular keyframes to control the exposure. Ads long as you have enough dynamic range in those images, you can pull up the shadows and exposure in order to control the resulting luminance when editing the keyframes. In your screenshot you seem not to have editied exposure at all.
Thanks for responding - my exposure largely went where I wanted it to go (corrected as I went while shooting), the problem I have is early in the shot, HG created some severe stair stepping - see the circled red area in the attached image. I haven't corrected anything in these screenshots to show the nature of the problem.

Later in the shot, using the same shooting technique, HG corrected no problem as usual. I'm just concerned about why some shooting adjustments unexpectedly resulted in this severe stair stepping in the corrected, rendered Visual Previews.

As you can see from the very first screenshot with the blue curve, at the beginning of the sequence, despite of the adjustment of the camera settings, the blue curve seems to be quite smooth. That means the adjustments of the camera settings are not being reflected in steps in the luminance curve. The reason might be the way how the camera changes the settings - this can happen, if you shot the beginning in A-Mode or Auto ISO, some cameras then make smooth adjustments, while they write discrete values into Exif.
In such cases the Exif Values will have steps but the luminance curve not. Since the Holy Grail Wizard expect accurate and discrete Exif Values to calculate the compensations, of course, it will introduce steps on a smooth curve, rather than removing them.

So maybe you can figure out, why the camera produced the smooth curve at the beginning. Some cameras have a setting for "Exposure smoothing" in the internal intervalometer, turn that off. Also don't use A Mode or Auto-ISO when shooting the holy Grail.

For this sequence, you could remove the 2*/3* keyframes (orange triangles) where the blue curve is already smooth and then rerun the holy grail wizard. It won't create compensations there then anymore.
Shot in full manual, and I ended up making my own keyframes and manually fixing. But was slow and tedious, and I still don't understand why it occurred in the first place, which is what I'm trying to figure out. This is my first Z7 shot I've fully processed, I have a few more shots from Hong Kong to try and process and I hope it doesn't occur again.
I've explained, that this is not a LRTimelapse issue, and why it happened.
The solution, to remove the orange triangles where the blue curve is smooth is not tedious at all, it takes a couple of seconds only.
Another way would be to just leave it and smoothen everything at the end via visual deflicker. No hassle at all.

Btw: With the Z7 make sure to not have exposure smoothing activated when shooting with the internal intervalometer.