LRTimelapse Forum

Full Version: TPLink Router problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have been using DSLRDASHBOARD with my nexus7 via the USB interface. It finds my Nikon D800E fine and works. I bought the TPLINK wireless router and followed the directions for configuring it. My nexus7 finds the router on wifi and using the browser I can get to the admin screen at with no problem. But when I start DSLRDASHBOARD on the tablet and select "Connect to OpenWrt/Linux" and use the server IP address of, nothing happens. (It doesn't give any messages about "unable to connect" or anything else.) It doesn't find the camera. But if I unplug the cable from the camera to the modem and plug it directly into the tablet, DSLRDASHBOARD finds it and works fine. What is wrong? Any ideas would be appreciated.


The new DslrDashboard V0.30.33 requires a new MR3040 firmware.
The new MR3040 firmware can be found here:

Please check the forum as there are many posts related to this.
Like this one:

or this one:
Thanks. I'll try it again being sure that I have the latest firmware. The forum posts you referred to seem to be about problems installing the new firmware on the router, which I did with no problem. I got the new firmware from your site just two days ago. After installing, I can access the router over wi-fi; it just doesn't work with Dslrdashboard. Maybe I missed something.
Just be sure you downloaded the latest version of the ddserver OpenWrt firmware. Google Code has disabled the download module so now the latest files are in my Google Drive account.
I have the same problem.
First I installed the openwrt-ar71xx-generic-tl-mr3040-v2-squashfs-factory on the mr3040 (the one with the switch for AP etc., it was only possible in the WISP-mode, in the AP-mode the IP of the PCwas different like 192.150.x.x and the Subnetmask and it was unable to conect with, but with the WISP-mode it was possible).
Than I installed the ddserver_openwrt-tl-mr3040-v2-squashfs-sysupgrade_0.12 and from your site the DslrDashboard_V0.30.33 on my Samsung SII.
My Nikon D7100 works fine with the USB-connection but if I connect the D7100 with the mr3040 and press on the Connect to OpenWrt/Linux nothing happen(no massege, nothing, the Wifi-connection to the MR3040 works fine, I can open the web-interface).

Is there any possibility in the web-Interface of the MR3040 to check if there is a connectio betwen the MR and the camera?


Found the problem, I forgot the check "keep settings", now it works.

Very fine!
I tried the solution posted above by hubaiz and it actually works for me now. My Nikon D800E connects wirelessly with Dslrdashboard and everything seems to be working.

Not being any kind of expert at this, I'm sorry I can't offer any suggestions other than to say that it now works for me.

hi Zoltan, I am new here, but i have used dslrdhasborad for a while with the otg cable, i just bought the tplink mr3040 (v2) because i really like the chance to remotely control my camera with all the posibilities that app gives us, but I found on youtube the tutorial (the same somebody posted in other thread), the thing is in that video the guy says and give a link to this image: "openwrt-ar71xx-generic-tl-mr3040-v2-squashfs-factory" and i followed the steps one by one and nothing happens. Then I read about the upgrade (openwrt-ar71xx-generic-tl-mr3040-v2-squashfs-sysupgrade) but nothing happens again. So I have the tplink with the last image i told you (both begins with "openwrt") and now I see that you say we have to install "ddserver_openwrt-tl-mr3040-v2-squashfs-factory_0.12" and "ddserver_openwrt-tl-mr3040-v2-squashfs-sysupgrade_0.12" I am really confused. The first ones that I installed doesnt work anymore? So i have to ask you, which one of all of this images do i have to install now on the router, do i have to uninstall the ones I have already installed and come back to factory settings in order to install the new image ("ddserver factory") or I can install directly the latest "ddserver factory" and/or just "ddserver sysupgrade" and finally get it work?

when I say "nothing happens" I mean the phone (galaxy s5) connects with the tplink through wifi, but the dslrdashboard doesn't connect when I press "connectWrt/Linux" it doesn't give any message of any kind, like "Snowpeak" told you before in his posting. I checked the connection in the phone's browser and is ok.
I tested it with the latest dslrdashboard and qdslrdashboard app, the 30.30 version hangs on my phone.

I have a galaxy s5 and a nikon d7000.

thanks and magnificent work, yours and Gunther's of course.
greetings from Chile.
Really having the same issue with my D700. got the router 3040 last week and downloaded the version 2 (3 position switch, checked under the battery). Charged it up. it connects fine via ethernet to my laptop. I can browse to it and log in. wirelessly my laptop connects to it fine.

Once i downloaded the usb driver recommended and installed it my d700 (which has always connected fine to my laptop and to control my nikon) was seen by the new software and i could use it in live view.

I think connected the usb cable (works fine usb connect to the tc router, and it doesnt discover my camera, with since click or holding down and entering address of router.

I DO see a solid green usb light when i connect it to the router. No idea why it cant be discovered as each piece seems to work seperately
for what its worth....
I was having problems connecting my Canon to the new qdslr. I tried everything.. flashing the firmware, reading checking all my settings and nothing. I was super frustrated.
Heres the small detail I forgot. I didn't connect deserver in the wireless connections on my iPad. I feel so stupid.......
anyway I connected the deserver in the wireless and qdslr works.

Hope this helps someone else.
How did you fix your problem?
Pages: 1 2