LRTimelapse Forum

Full Version: Panasonic LUMIX LX5 Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am trying to connect mt Samsung Note 10.1 2014 to a Lumix LX5.

I bought a TP Link 3040 that has the 3 position switch. I tried Flashing the v2 FW and it wouldn't Flash and said wrong version. Then I looked at my Router and it said v2.2 under the Battery cover but said version v1 in the FW webpage??

So I flashed v1 FW and it worked.

Tried connecting to a Nikon D2X and that really didn't work well, but it did read a file one time.

So waited for a cable for my Lumix LX5.

Got the cable today, set the Lumix to PTP.

DD connects and "sees" the Panasonic by displaying the camera name up top but that's it, nothing else.

I upgraded the FW to the sysupgrade v1 .12.bin FW.

No change, I uninstalled the Beta version of DSLRDashboard and put the Play store versionon, same thing. Just displays the name and nothing else.

I'm batting zero here so far!

D2X -- Not doing anything
Lumix LX5 -- Not working
Gonna get a D800 and just read the shutter won't trigger!

What am I doing wrong here?
Any idea why my TP link took the wrong FW?

Really would like this SW to work with my LX5 and D800!
The application only supports Nikon and Canon DSLR. I would love to add more DSLR to the list but unfortunately the vendors do not publish any documentation for their DSLR, and I don't have founds to invest into every DSLR (the only vendor that publish documentation for developers is Nikon)
The Lumix LX5 is not supported (there is no documentation for developers)

For the Nikon D2x I don't know as it is an old model and there is no SDK for it from Nikon. Check if it has a PTP USB mode, and if yes turn it on.

Current Nikon models that will work: D40, D60, D80, D90, D200, D300, D700, D3, D4, D5x00, D6x0, D800, Df and the budget D3x00 models (they have only a limited set of PTP commands/properties)
Thanx for the quick reply. I thought I had seen a list that showed the LX5 as compatible.

I'll quit trying on that one.

No possibility of getting shutter control of the D800 in Live View I guess?
>>No possibility of getting shutter control of the D800 in Live View I guess?

What do you mean?
I thought I saw that if the D800 is in Live view that you cannot actuate the shutter?
You can but only from the application. The camera shutter release is disable (as a remote release). This is not an application limitation.
OK, that would work.

So if the app is running, you can't hit the shutter release on the camera, but you can trigger the shutter in DSLRDASHBOARD?
With Nikon DSLR you can operate the camera shutter button or remote release if the camera is not in 'host mode' and not in live view.
OK, thanx!