LRTimelapse Forum

Full Version: OpenWrt root password issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there

I installed the newest firmware on the TP-link Router. It asked me for a username and password. I put these in and after this it gives me this screen.

Authorization Required
Please enter your username and password.
Invalid username and/or password! Please try again.
Username Root
Powered by LuCI Trunk (svn-r9925) OpenWrt Barrier Breaker r38444

The user is root by default. I have tried as password blank, admin and anything else I can think of to get access to the router. I have also tried the username and password that I put in at the beginning. I have also tried to put the router in safe mode.

Maybe I am having a blond moment.
Please advise my next steps.
Any help would be greatly appreciated.
You should have a warning if the root password is not set when you open the OpenWrt web admin.
If you set the root password and you can't remember it the only way to change it is to go into safe mode and change there with telnet.

To enter safe mode follow these steps:
1. Turn on the router
2. Wait almost 5 sec
3. Press the 'Reset' button on router for ~3sec
4. The device will enter failsafe mode (while in failsafe mode the LED's won't flash)
5. Access the router with telnet at (on windows you can use PuTty)

You will need to connect the MR3040 with your PC with network cable and access it with telnet (u can use PuTTy)
After you loged into router with telnet you can use the
command to change the root password.
Hi there

Tried this and it did not work.
I think that I installed the DSLRcontroller frimware by mistake the first time.
This is why I could not access it. So I used the DSLRcontroller password.
I tried to re-install the Openwrt firmware.
This did not make a difference.

I then tried to install the factory router firmware...
And when it restarted it bricked my router. Sad

Will try again with a new router.
Slow learning process but I am learning fast.

Thanks for the advice.
You could update the firmware if you figured out the password.
Here is the upgrade procedure:

Restoring the original firmware isn't that easy, it is documented here: (see under Restoring Original Firmware)

If you have experience with electronics you can unbrick the router: