LRTimelapse Forum

Full Version: App quits during Holy Grail - what to do?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Crossposted on the DSLRDASHBOARD.info site as well...

Greetings,

Testing qDSLR on my Nexus 7 (2013) connected via USB to Nikon D600 triggered by Emotimo TB3.

Several times over the 1 hour sequence, the app stopped responding, and crashed. It's connected via USB to rule out any wifi-issues (as this was also happening while using the wu-1b). When I attempt to reestablish connection, the app launches with a black screen. I have to go to apps, and force the app to quit. Then I restart the Nexus, relaunch the app, relaunch LR function and then relaunch the Holy Grail...

So here's my question... other than "Why is it crashing, and what can I do?" is a more practical question...

What happens when qDSLR crashes during a Holy Grail sequence? I can't/won't stop the sequence - because there's no "redo" - so if I reestablish connection to qDSLR, and relaunch the LR Timelapse setting, and reinitialize the holy grail sequence, can I just pick up from the settings it sees at that moment? Does the Holy Grail sequence rely on settings set at the beginning of the sequence (pre-crash) to work? or can it work from a "current" setting - such as...

Sequence started at 1/250th at ISo 400. As the sun set, the exposure changed to 1/60th at ISo 400, then BANG, the app quits. I disconnect the USB, restart the Nexus 7, relaunch the app, restart LR setting, etc. and the exposure is where it left off - 1/60th ISo 400. This process takes about 1 minute, so it's not a total disaster if I'm there when it happens, but no beer or bathroom breaks for me... I still have to babysit the thing! So when it's reestablished, exposure of 1/60th ISo 400 is still fine - Do I just "continue" by starting a NEW Holy Grail sequence? (the counter resets to 0/1, the elapsed time resets to 0:00).

OR

Is all hope lost - and once quit, the sequence can't restart?

So, while it would be great to solve the "Why does it quit" question, it's more practical to explain the "Ok, it's quit, now here's what to do to save the shot".

THANK YOU VERY MUCH IN ADVANCE!! Only have 5 more chances to "master" this before my vacation starts...

mb
You can just restart the Auto-Holy grail, no problem.
But it is interesting, that it crashes so ofter for you!

I'm on the nexus 7 as well, but I always use WiFi via TPLink or directly to the 6D. Maybe Zoltan can make some stability tests as well via USB.
Thank you for checking - i have tried USB, but also tried directly connecting to the D600 via the Wu-1b Wifi adapter. The crash is just as frequent via USB or via wireless.

fingers crossed that Zoltan thinks of something!
I answered on dslrdashboard forum but will do it here to.
I found a memory leak error in the image download code and probably that is the error source you where experiencing.
I will release a new version during next week (mostly error and stability fixes) that should fix this.
Also I was thinking after your post and will see if I can add a 'fail safe' save of the LRT parameters that would be loaded if qDD would crash during LRT session.
thank you zoltan!
Yes, thanks very much for chasing this up!

I've been having some DDB crashes too (particularly when starting a sequence - it seems more stable once underway).

I've been wondering if this could be related to the fact that I'm using a wireless intervalometer (Pixel TW-282RX) as well as a wireless WU-1b connection to DDB. Do you believe this could cause interference? Again, the combo seems fairly stable once both connections are established, but starting up is iffy (prone to DDB crashes).

I'll be keen to try the new version once available Smile
Hi Zoltan, if you are reading this: 1.0.5 is still crashing some times in the middle of the holy grail.
hello everyone: same problem as you refer using
- the new qdsrldashboard app
- Canon 6D y wired conexion to nexus 7
- Photix intervalometer that works ok, I think..

when crash I normaly can reconnect but sometimes no.

Happy to see that this not only is happening to me Smile
Jose,
could you please test it with the new Canon method as well?
Thank you. I'm sure Zoltan will try to fix soon, it if he finds a way.
Best
Gunther
Gunther, can you briefly explain this Canon method? Thanks.
Pages: 1 2