LRTimelapse Forum
Folder on NAS show no files - Printable Version

+- LRTimelapse Forum (https://forum.lrtimelapse.com)
+-- Forum: LRTimelapse 4 and older (https://forum.lrtimelapse.com/Forum-lrtimelapse-4-and-older)
+--- Forum: LRT4 - General Questions (https://forum.lrtimelapse.com/Forum-lrt4-general-questions)
+--- Thread: Folder on NAS show no files (/Thread-folder-on-nas-show-no-files)



Folder on NAS show no files - achimhb - 2018-05-28

LRTimelapse 4.7.6 Pro show on my NAS (Synology) the folder tree and number of files in every folder but no files at all? File list is empty. Local drives work well.
Of course Explorer show every file on my NAS. I am using Windows 10 Ultimate.
Last time (about 8 weeks ago) everything was fine. Maybe the result of some Windows update?


RE: Folder on NAS show no files - gwegner - 2018-05-29

I don't really know. You should have mounted the NAS as drive, then LRTimelapse will be able to access it as every other internal drive. I'm working with the latest W10 here and can work on my NAS files without problems. Please double check! Sometimes the NAS goes to sleep, then you might have to open a folder in Explorer on the nas first to activate it. Make sure to click on the small blue "reload" arrow on top of a folder selector in LRT to update the contents.


RE: Folder on NAS show no files - achimhb - 2018-05-30

Hmm,
At least the April 2018 update could affect the access. As SMB1 is deprecated in this Update many NAS user have at least to change some advanced setting else you got NO access, for example to assign a drive letter. MANY NAS user must change the settings.
But I changed the settings and got access by using Explorer for example over assigned drive letter and UNC. 
LRTimelapse can show how many files are in a folder but NO file at all. Of course only files on NAS. I am using 3 different NAS (all different 12 bay systems from Synology) and it is everytime the same. So I guess someone else must have this problem.


RE: Folder on NAS show no files - gwegner - 2018-05-31

That's strange, since LRTimelapse does nothing special on those drives, just sees them as regular drives. Currently I'm a bit lost on how to help you I guess. I'll see to install the Spring 2018 upgrade in the next days and see if I can access my QNAP network drives.


RE: Folder on NAS show no files - gwegner - 2018-05-31

Ok, I've just upgraded my W10 to 1804 and can confirm, that there are no issues with my network drives.

Please check the log (info/show log) after you loaded a folder that contains a timelapse sequence but doesn't display the content in LRT. Send it over via email.


RE: Folder on NAS show no files - achimhb - 2018-05-31

Solution: Synology NAS user with problems must change settings and use SMB2/SMB3 instead of SMB1 AND you need to update to latest firmware (available since end of May 2018). This will solve the issue. Else some software will not work. It's all because Microsoft deprecated SMB1.


RE: Folder on NAS show no files - gwegner - 2018-05-31

It might also be able to reactivate SMB1 via Powershell:

Code:
Enable-WindowsOptionalFeature : -Online -FeatureName smb1protocol

I didn't test it and I'd not recommend this. Microsoft deprecated the old SMB protocol for security reasons.