LRTimelapse Forum
Strage behaviour with Canon 5D MKIV... - Printable Version

+- LRTimelapse Forum (
+-- Forum: Time Lapse Shooting (
+--- Forum: LRTimelapse and qDslrDashboard Auto-Holy-Grail Ramping (
+--- Thread: Strage behaviour with Canon 5D MKIV... (/Thread-strage-behaviour-with-canon-5d-mkiv)

Strage behaviour with Canon 5D MKIV... - Jiheffe - 2019-08-20

I am posting this here because I got an error message when trying to post this in the forum, stating my IP address is blacklisted????



I'm using a Canon 5D MkIV in combination with TP-Link 3040 and an iPad to do holy grail timelapses. The camera shutter is controlled by either LRTimelapse Pro Timer 2.5 from Günther Wegner, or the PINE controller from BFM. All firmwares at latest versions, as well as ControlMyCamera on the iPad.

I noticed a strange behaviour, can't remember if it was the same when I was using a 5D MkIII. When I connect the camera to the TP-Link by USB, the camera becomes unresponsive. I can't dial shutter speed or aperture, can't autofocus, .... Whathever I do, I get a message "Busy" on the top LCD display of the camera. Only when I start ControlMyCamera and connect to the camera, will the camera respond again and let me do my settings.

Last time, I used another iPad as the usual one, and I forgot to tick "Keep screen on" in ControlMyCamera... At a certain moment, I noticed no shutter sound anymore. The PINE app was still showing shutter count increasing, as if all was normal. I then noticed the iPad had gone to sleep. So I went into ControlMyCamera and connected again to camera, and the shutter sequence resumed.

Any idea if this is normal behaviour?


RE: Strage behaviour with Canon 5D MKIV... - hubaiz - 2019-08-20

Yes it is. If CMC goes into background iOS will cut the wireless to it and by that CMC will lose the connection with camera. Contact me with the support email to see what is it with you forum login.

RE: Strage behaviour with Canon 5D MKIV... - Jiheffe - 2019-08-20


I understand that when the iPad goes to sleep, CMC looses control over the camera.

But what worries me is that "Busy" indicator on the camera and the camera being inoperative when connected to the TP-Link, but CMC has not the control over the camera. I have to either disconnect the TP-Link, or connect with CMC to the camera to get rid of that "Busy" indicator. That "Busy" indicator comes on whenever you manipulate the camera (trigger, dial, button) and goes away when you release it. When in that state the camera will also not respond to trigger impulses from PINE.

Other way to put the issue: I am using CMC to control the exposures settings, not the actual shutter triggering, with is done by PINE. So when CMC shuts off, I would suspect the PINE triggering to continue, and CMC would resume the exposure control when reconnected to the camera. The problem is: as soon as I connect the camera to the TP-Link, it becomes non responsive and ignores the trigger signals from the PINE. Only when I fire up CMC and connect to the camera, will the camera start reacting to the trigger signals of the PINE.

I will send you the error report I get on your forum!


RE: Strage behaviour with Canon 5D MKIV... - hubaiz - 2019-08-20

Most of the cameras have this behavior, after they are connected with USB they switch to PTP mode.

RE: Strage behaviour with Canon 5D MKIV... - Jiheffe - 2019-08-23

I did some further investigations. I cannot remember I had this problem with my "old" 5D MkIII, but I have not access to it at the moment, so I cannot test. I did however a test with a 7D MkII in firmware 1.0.5, and I had no problems. I then flashed it to the latest firmware (1.1.12) and the problem is now also on the 7D... So it looks like Canon introduced a change in their latest firmwares that makes the camera go in this "Busy" mode as soon as a USB connection is detected. In order to get is reactive you need to connect to it, E.g. with QDDB.

This is a real problem when shooting Holy Grails with QDDB and an external intervalometer. This is recommended because whenever QDDB or the tablet would crash or go to sleep, the sequence would continue thanks to the intervalometer continuing to trigger the camera. You could just restart the tablet with QDDB and resume monitoring and adjusting the sequence. NO SO ANYMORE, at least not with Canon :-( . If something goes wrong in the tablet or QDDB, the camera will go in "Busy" mode and stop listening to the trigger port, and the sequence will be interupted.

Strage behaviour with Canon 5D MKIV... - gwegner - 2019-08-24

Sounds bad. I guess anyone will have to contact Canon about this.
Does it still work via wifi?

RE: Strage behaviour with Canon 5D MKIV... - Jiheffe - 2019-08-24

Hi Günther,

Your question "Does it still work via wifi?" intrigated me... I never tried connecting directly to the camera, using the built-in Wifi function in the 5D MkIV. I thought it only worked with the Canon Camera Connect app on the phone... And so I discovered it works perfectly with CMC as well! No need for TP-Link anymore! BTW, it also works with E.g. ShutterSnitch, so no need for an EyeFi card anymore as wel :-)

Back to this "Busy" issue... Yesterday evening I shot a sequence using a PINE controller, TP-Link and QDDB. At the end of the sequence, I wanted to replicate the problem once more, and let the PINE continue its triggering, while shutting down QDDB and the tablet. I expected the camera would go into "Busy" and the triggering would stop, but not so! It went happilly on... Power cycled the camera while still connected to the TP-Link, it was again in "Busy"mode... I don't get it anymore ;-)

Anyway, will try to find out where to report this to Canon.

Strage behaviour with Canon 5D MKIV... - gwegner - 2019-08-27

If you find a pattern, please let us know!