LRTimelapse Forum

Full Version: Keyframes, Metadata, Editing from LRTimelapse not visible in Lightroom or vise versa
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7
Most important: please be aware, that after reloading Metadata in LRTimelapse, the previews will not update directly. This has performance reasons - it just doesn't make sense to update the previews now, since you would overwrite those with the next steps. So - after coming back from Lightroom to the second workflow row in LRTimelapse, just ignore the previews for a moment. You'll see the changed values on the keyframes in the table. Proceed through the 2nd workflow row and hit save at the end. Now in the 3rd Workflow row you will activate the "Visual Previews" - those will then render the changes visually.

If this is not your problem, you might have a workflow issue. Some things to check:
  • Go to the Lightroom Preferences / Catalog Settings. Make sure that "Automatically write changes to XMP" is OFF!
  • Are you working on the same folder in LRT and LR? You might have incidentally copied the sequence when importing into LR - then both programs might be working on different folders with different copies of the same sequence inside! Always make sure to have "Add" selected when importing into Lightroom (not copy!). See
  • Are you aware of the fact, that you won't see the changes visually in the LRTimelapse preview, since LRTimelapse does not actually apply the development settings in the "regular" preview. You will however see the table values change and as most important indicators you should see the changes in the curves overlaying the preview. The yellow curve resembles the "Exposure" setting. You can select other values with the dropdown box above the preview. You might as well check the "ALL" Button, to see all curves! Since LRT4 you can enable the "Visual Preview" feature to see the developed images with all edits!
  • Have you initialized the sequence in LRTimelapse as first step (in LRTimelapse 4 this will happen automatically - but when trying to sort out any problems, it might make sense to use Metadata/Initialize from the menu, to start over with a clean set of files).
  • Make sure always to do the Metadata Loading and Saving from the Lightroom Library / Grid-View (not develop-module!) - please get used to this pattern for all operations in Lightroom, that should affect all images!
    G (to go to Grid-View in Library), check the filters, Ctrl-A (to select everything), then Load Metadata from files / Save Metadata from files.
    In the develop-module, even if the whole sequence is selected in the filmstrip, LR will only apply those commands to the current image, thus leading to confusion.
  • Are you only using the supported tools when editing? Please take special care on the right use of the gradients!
  • Are you taking all settings over to the next keyframe when editing to have the same basis? With LRT4 you have to use the "Sync-Script" from the Scripts menu, not "Copy/Paste" - check out my tutorials!
  • Are you applying the Auto Transition? After that you should check the curves of the changed parameters? (drop down top right of the preview) - check if the are looking right (in LRT3 there is a button "ALL" where you can see all curves as overlay) - you will then see if the curves have consistency or not.
  • Please check your camera date! If the camera date is in the future, Lightroom does not save/read metadata correctly! LRTimelapse will detect this since version 3.3 and offer to correct it. Please make sure you have the latest LRTimelapse verision installed!
  • If you still use an older LRTimelapse version, please note that newer Lightroom tools cannot be supported there. If you want to use Lightroom 6/CC you would have to upgrade to the latest LRTimelapse 4.
If anything looks right in LRTimelapse and you save then make sure in Lightroom to have no filter applied when loading the metadata for the sequence. Try this and please check it again.

Update: Here is a step-by-step troubleshooting guide that allows you to track, how your metadata values are traveling between the programs. Please try this, if the tips above did not deliver the desired results.
  1. Reset all edits in LRTimelapse: Clear Metadata (Metadata menu), save, right click on folder, "clear all LRT edits".
  2. Remove the folder from Lightroom.
  3. In LRT: Metadata: Initialize.
    This should give you a clean sequence.
  4. Use the keyframes wizard to create 2 keyframes, one at the beginning and one at the end.
  5. double click on the exposure 2012 value in the table for the first image (keyframe), enter "1.0"
  6. double click on the exposure 2012 value in the table for the last image (keyframe), enter "2.0"
  7. Drag the sequence to Lightroom, make sure to have "add" selected in the import dialog
  8. Set the filter in Lightroom to "LRT Keyframes" - Check the keyframes: first and last image should have 4 stars - first image an exposure of 1.0, last image an exposure of 2.0.
  9. Change the Exposure of the first image to 1.5, the exposure of the last to 2.5
  10. Grid View (G), Metadata->Save Metadata to files
    *Here you could check, if Lightroom is writing the values to the XMP files properly, by right clicking on the first image, then "Show in Explorer/Finder", and then open the XMP file with the same name as the selected image file in an text editor. Check the value for "Exposure 2012" - if it's 1.5, then LR has written the metadata correctly.
  11. In LRTimelapse: Reload - check the table you should see 1.5 in the Expsure 2012 column for the first image and 2.5 in that column for the last image.
  12. Now apply auto transition
  13. Exposure 2012 column should get a linear transition from 1.5 to 2.5. You'll see this in the preview as tilted yellow line too.
If this still doesn't work, please tell me exactly at which step you experience any anomalies.
I'm working with LRT 4 and LR 4. I have done everything in this list and my LR edits don't show up in LRT. Is there something I'm missing? Is there an online chat I could work with someone to help figure this out? Thanks
Make a simple test: Clear all filters in Lightroom, select the very first image. Set exposure to +1 in Lightroom, then Metadata/Save Metadata to files. Now switch to LiRTimelapse, open the sequence or click on "reload", if it's already opened. Now check the "Exposure 2012" column in the table for the first image. Do you see the +1 value?
Thanks for the reply!
Yes the +1 is there but I don't see the changes in the preview window so I can't see how my time lapse is progressing.
I've been spending most of my day trying to figure this out and I found on here that other people have also been having a problem with the visual preview. I think I've tried everything and downloaded the new 4.0.3 today but that didn't change anything. It looks like you asked some other people for their log info so here is mine if you could please help me asap would be much appreciated. Thank you.

Support request from Crispin Cannon, , Garibaldi Highlands, EMail:
License for: LRTimelapse 4, License type: professional, Payment reference: PayPal, Valid until: Lifetime

[2015-05-11 20:57:09] DEBUG: Loading properties from /Users/crispincannon/Library/Application Support/LRTimelapse/user.props
[2015-05-11 20:57:09] INFO: LRTimelapse 4.0.3 (2015-05-11)
[2015-05-11 20:57:09] INFO: © 2015 Gunther Wegner
[2015-05-11 20:57:09] INFO:
[2015-05-11 20:57:09] INFO: Java version: 1.8.0_40 (64bit) from Oracle Corporation
[2015-05-11 20:57:09] INFO: Running on: Mac OS X locale: en_US
[2015-05-11 20:57:09] INFO: Java runtime: 64 bit
[2015-05-11 20:57:09] INFO: ------------------------------------
[2015-05-11 20:57:10] INFO: Licensed to: Crispin Cannon, , Garibaldi Highlands - Professional License.
[2015-05-11 20:57:10] DEBUG: Initializing directory chooser.
[2015-05-11 20:57:10] INFO: Done (dirchooser)...
[2015-05-11 20:57:11] DEBUG: Launching ExifTool: exiftool
[2015-05-11 20:57:11] INFO: ExifTool: 9.90
[2015-05-11 20:57:11] DEBUG: Exif Tool available.
[2015-05-11 20:57:11] DEBUG: DNG Converter available.
[2015-05-11 20:57:11] DEBUG: MPEG Encoder available.
[2015-05-11 20:57:11] INFO: Detected Screen size: 1440 x 900
[2015-05-11 20:57:15] INFO: Newest version: 4.0.3 (2015-05-11), current Version: 4.0.3 (2015-05-11)
[2015-05-11 20:57:23] INFO: --- Loading directory: /Users/crispincannon/Desktop/Tripple New
[2015-05-11 20:57:25] DEBUG: Memory: [max|1820] [used|148] [free|1672]
[2015-05-11 20:57:25] DEBUG: Loading sequence properties from /Users/crispincannon/Desktop/Tripple New/.lrt/
[2015-05-11 20:57:25] WARN: Properties-file not found.
[2015-05-11 20:57:25] DEBUG: Buffer size for ExifTool: 66
[2015-05-11 20:57:41] DEBUG: Sequence shot in manual mode
[2015-05-11 20:57:41] DEBUG: Timestamp Data complete!
[2015-05-11 20:57:41] DEBUG: Sequence is new or was processed with LRT < 4.0
[2015-05-11 21:02:06] DEBUG: Done loading previews.
[2015-05-11 21:02:06] DEBUG: Memory: [max|1820] [used|791] [free|1029]
[2015-05-11 21:04:52] INFO: 666 XMP-files successfully saved.
[2015-05-11 21:14:37] INFO: Reloading XMP only...
[2015-05-11 21:14:37] DEBUG: Timestamp Data complete!
[2015-05-11 21:14:40] DEBUG: Buffer size for ExifTool: 66
[2015-05-11 21:14:40] DEBUG: Sequence shot in manual mode
Hi Gunther, some help on this would be great otherwise my program is useless. Thanks!
The log file shows nothing special.
It does not show that you even switched to visual previews. So this is again, what I already wrote you via email:

LRTimelapse "normal" preview doesn't visually reflect the changes. You'll see the changes in the table and in the curves.
The new "Visual Previews" feature in LRT4 does show the changes visually in LRTimelapse at the end of the workflow. Please check my tutorial videos to learn how the LRTimelapse workflow works. The Visual Previews are explained there as well.

I'll need more information what exactly you are doing, what you are expecting to happen and what actually happens. I hope, you have watched my tutroials to learn the difference between normal and visual previews.

Should the visual previews not reflect the changes, make sure to have the latest DNG Converter installed.
Sorry Gunther this is my bad and I feel bad, I somehow didn't catch that my DNG converter was not up to date.
Appologies and thanks for such an awesome program.
My Programs version ;

Lightroom 6.1
Camare Raw Version 9.1
Lrtimelapse 4.1

I Am not see my lightroom 6.1 Keyframes,metadata

I did try This First Page written.
But not working.
How Can I Solution ?
All solutions are written in the first post on this page. Please recheck them carefully, I'm sure you are doing something wrong. Most likely you are working on a copy of the sequence in Lightroom that is on another location, please check this again and the other tips given.
Pages: 1 2 3 4 5 6 7