• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Unable to Export Error

Offline
#1 toolsup
I upgraded to LR5 last night and re-did a timelape I shot a week ago.

After I went throught all the steps and went to LR Classic 7.1 and tried to export using LRT (JPG, 4K) preset and I got the error below.

bad argument #1 to '?' (string expected, got nil)

I did the following but I am still getting the error.
  • Confirmed the output path
  • Confirmed the executable path
  • Uninstall and reinstalled LR5
  • Reloaed the plug-in in the plug-in manager
I can export single and pultiple images using other presets.

I am not sure what to try next. Any idea's?
Offline
#2 gwegner
Please distinguish between the original raw sequence, which you would load into LRTimelapse, and the exported "Intermediary Sequence", which is the exported JPG or TIFF sequence from Lightroom and is located inside a folder "LRT_<Name of your Sequence>".
To rerender the once exported intermediary sequence, go to "File / Render Video" in LRTimelapse. No need to load any sequence into the main window of LRTimelapse first. In the render Dialog click on "Choose" on the top right, select the Intermediary Sequence (Shown blue) and then set your render settings and render.

If you export again from Lightroom, of course it will ask you, if you want to overwrite, because the intermediary sequence is already there.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#3 weetiong
Had a similar error after installing LRT5.0.1 on LR Classic CC 7.1 on Mac OS X 10.13.3. Error was: "This plug-in’s post-processing task did not finish successfully. LRTExportTask.lua:408: attempt to index field '?' (a nil value)". This happened right after checking sequence, aspect ratio, and created destination folder. I reloaded plugin, reinstalled LRT5 but to no avail. I also suspected it could be due to the symlink issue (posted in separate thread) thus I tried to export right after I reinstalled LRT5 where the presets were in the default folder. Same error. Thanks!
Offline
#4 dfs6
I have LRT ver. 5.0.2 and the error I get:  "Wrong LRT export Plugin that corresponds to your LRTimelapse version"  My plugin version is "LRT Export 4 ver. 4.8.3.3153.  How can this be corrected!  Thanks.
Offline
#5 gwegner
Normally, when you install LRT5 the Plugin will be updated to 5.x as well. You cannot export with the old plugin, when you are using LRT5.
I'd recommend to uninstall all LRTimelapse versions from your computer. On windows use add/remove programs from control panel, on mac use the provided uninstall script in the DMG installer archive.

Then check your Lightroom settings, make sure it's not set to store the presets with the catalog - see: https://forum.lrtimelapse.com/Thread-lrt...-installed

Close Lightroom.
Now reinstall LRTimelapse.
Open Lightroom, everything should be working.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#6 dfs6
All is working now.  I shut my computer down, then rebooted and checked the plugin version and it had updated.  By the way, i am using a Mac.  I am new to LRT and just edited and rendered my first two projects for practice.  Thanks for your response.
Offline
#7 mas_vie
Mac OS 10.13.3, LR 7.1, LRT 5.0.2 and i'm always getting this error:

An internal error has occurred: LRTExportTask.lua:407: attempt to index field '?' (a nil value)

Reboot done, uninstall of LRT and LR done. no change ...

Any Ideas?
Offline
#8 mhollamon20
I have LRT 5.0.2 installed and am getting the "wrong LRTExport version used" message. Lightroom shows export version 5.0.0 build 525. I'm on a PC and have uninstalled x2 so far. All other versions have been deleted and Lightroom is not set to store the presets. Any ideas on this? thank you in advance!
Offline
#9 gwegner
You'll only get "wrong export version", if the version of LRT and the LRTExport plugin don't match. So if the export plugin is the latest, probably you have LRT4 still installed and the Export Plugin is trying to call LRT4. Please uninstall LRT4, then open the LRTExport Plugin again and check the "Path to LRTimelapse" in the advanced setttings panel. Make sure it's pointing to LRT5!
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#10 mas_vie
Intersting ... it just seems to happen when i try to export files from two different folders at once (i used the 2018 folder and not the 2018-02-10 folder ...)

...also check out: