• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Genauigkeit Arduino Uhr

Offline
#1 elron
Das Projekt gefällt mir gut. Mit der Anleitung haben wahrscheinlich auch Arduino Anfänger kein Problem beim Nachbau.

Wie verhält sich mit dem Arduino Modell die Zeit über einen längeren Zeitraum? Ich hatte mal vor Jahren, bei einer DIY Teleskopnachführung, das Problem das die Zeit immer weiter auseinander lief. Die millis Funktion nimmt ja die Taktzyklen den Arduino als Referenz und die sind nicht sonderlich genau weil der Quarz am Arduino nicht genau genug ist für eine "richtige" Zeit. Nebenbei ist der Quarz auch temperaturabhängig.
Wenn man das Problem lösen will braucht man noch eine Echtzeituhr wie das DS1307 Modul. Beim Timelapse fällt es wahrscheinlich gar nicht auf wenn die Zeit etwas abdriftet. Zum Testen kann man ja mal am Handy eine Stoppuhr daneben legen und nach ein paar Stunden schauen wie groß der Unterschied ist.

mfg
Online
#2 gwegner
Hallo Elron, geringe Zeitdifferenzen sind bei Timelapse völlig vernachlässigbar. Wichtig ist nur, dass die Intervalle immer gleich sind. Eine Millisekunde länger oder kürzer macht nichts aus.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#3 rmsigrist
(2017-01-21, 14:35)gwegner Wrote: Hallo Elron, geringe Zeitdifferenzen sind bei Timelapse völlig vernachlässigbar. Wichtig ist nur, dass die Intervalle immer gleich sind. Eine Millisekunde länger oder kürzer macht nichts aus.

Lieber Gunther

Zunächst ganz herzlichen Dank, habe 2 Stück zusammengebaut. Eines funktioniert einwandfrei, das andere nicht ganz. 
Habe folgendes Problem (wie gesagt, lediglich auf einem der beiden ProTimer):
- bei Intervall = 3s sowie Intervall = 4s löst die Kamera nicht regelmässig aus (bei 4 zum Beispiel jedes zweite Mal, das heisst also wie wenn Intervall = 8s; bei Intervall = 3s kann ich keine Regelmässigkeit feststellen, teils wird korrekt ausgelöst, teils nicht)
- Folgende Intervalle habe ich ebenfalls ausprobiert: 1s, 2s, 5s, 6s => Hier funktioniert der Timer einwandfrei

Deshalb verstehe ich nicht wo das Problem liegen kann, wenn es nur die beiden Intervalle 3s und 4s betrifft? Hast du vielleicht eine Idee?

Vielen Dank für deine Bemühungen!


Ps: noch eine Nebenfrage: Hast du den Timer jemals im Handgepäck mitgeführt? Gab das Probleme?
Offline
#4 MMeier
Hi
Zu deinen Problemen mit der Auslösung kann ich leider nichts sagen, ich kann dir nur meine Erfahrung zum Handgepäck weitergeben. Ich hatte meinen Auslöser auf der letzten Reise im Handgepäck und bei keinem der Sicherheitskontrollen war das ein Problem und bei einer haben sie mich den Rucksack ausräumen lassen und auch dann dem Timer keine Aufmerksamkeit geschenkt.
Viele Grüsse


Gesendet von iPhone mit Tapatalk
Online
#5 gwegner
Time im Handgepäck ist überhaupt kein Problem. Da sind ja nur 4 AA Akkus drin.
Das mit den 3 und 4 Sekunden halte ich für äußerst merkwürdig. Würde eher auf einen Wackelkontakt tippen, zumal es ja nur das eine Gerät betrifft.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#6 rmsigrist
(2017-03-25, 20:13)gwegner Wrote: Time im Handgepäck ist überhaupt kein Problem. Da sind ja nur 4 AA Akkus drin.
Das mit den 3 und 4 Sekunden halte ich für äußerst merkwürdig. Würde eher auf einen Wackelkontakt tippen, zumal es ja nur das eine Gerät betrifft.

Vielen Dank für eure Antworten!
Habe die Lötstellen nochmals nachkontrolliert, kann leider nichts finden. Habe noch etwas genauer hingeschaut und herausgefunden, dass meine EOS 6D jeweils ein Signal erhält (Display zeigt Blende, etc an), aber sie löst bei Intervall = 4s einfach nicht aus. Es muss somit irgendwie mit der Kamera zusammenhängen.
Offline
#7 mzwick
ich habe genau das gleiche Problem an einer Canon 5DS. Mit dem selben Auslöser an einer Canon 5DMark II funktioniert es. Andere Auslöser von Photoix gehen an beiden :/
Online
#8 gwegner
Versucht mal die Trigger-Zeiten etwas hochzustellen: https://forum.lrtimelapse.com/Thread-tip...instellung
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo

...also check out: