• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Lightroom / LRT4 transfer issue

Offline
#1 gregm
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]Hi, I posted this in another forum but thinking about it, I suspect it's a bug if you use jpg files as I had no issues with canon raw files[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]I would not normally save in jpg but I have to occasionally reset my 5D Mk3 as it sometimes gets in a state that it ignores the manual/auto switch on the lens. The default is jpg after the reset & I forgot to change it back to raw before doing a star timelapse.[/font]

[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]---------------- earlier post  with updates --------------------------[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]I've been having issues with a timelapse that uses jpg files. I've had earlier multiple successes with timelapse using RAW files.[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]This timelapse uses 489 jpgs from a canon 5D Mk3 (using 1.3.3 firmware)[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]I have LRT V4.6 and lightroom CC 2015.5.1, a 27in iMac with El Capitan  10.11.5 & all software up to date. [/font]

[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]I tried the 13 step update at [/font][font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]http://forum.lrtimelapse.com/Thread-keyf...vise-versa[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]I got to step 8 which did not work. ie. the 4 stars in the first and last images did not show up in lightroom.[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]I then read the metadata in lightroom and the 4 star files showed up (with the +1 & +2 exposure increases) so now step 8 was good[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]I did step 9 & 10[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]step 11 did not work. The two key files remained at +1 & +2 exposure[/font]

[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]Any suggestions ?[/font]

[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]regards[/font]
[font='Open Sans', 'Myriad Pro', Tahoma, Verdana, Arial, sans-serif]Greg[/font]
Offline
#2 gwegner
Hi Greg, it's hard to say what's happening there - normally JPGs are supported without problems. The difference is, that Lightroom will save the XMP data right into the JPGs, while LRTimelapse will save it as sidecar files. But both programs will read whichever information is never, so the workflow will work exactly the same way.

I'd recommend trying once more, starting with initialization. If it again does not work, please send me the logfile (info-menu / show log) and a short test sequence, where I can try to reproduce. Please use Dropbox or Wetransfer to send the sequence.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#3 gregm
Hi, I've done a few experiments trying to debug the issue. Both of these experiments use the first 10 photos of the 490 photos taken. I had no problems with either experiment

First, I followed the 13 steps with a slight modification. The second, I tried a normal timelapse with the 10 photos
----------------------------
1. a) Reset all edits in LRTimelapse: Clear Metadata (Metadata menu),
b) save,
c) right click on folder, "clear all LRT edits".
2. Remove the folder from Lightroom. (was not in lightroom)
3. In LRT: Metadata: Initialize.
This should give you a clean sequence.
4. Use the keyframes wizard to create 2 keyframes, one at the beginning and one at the end.
5. double click on the exposure 2012 value in the table for the first image (keyframe), enter "1.0"
6. double click on the exposure 2012 value in the table for the last image (keyframe), enter "2.0"

6a – “save” after entering 2.0 above
(this is not in the instructions but thought was needed to ensure lightroom picked up info)
7. Drag the sequence to Lightroom, make sure to have "add" selected in the import dialog
8. Set the filter in Lightroom to "LRT Keyframes" - Check the keyframes: first and last image should have 4 stars - first image an exposure of 1.0, last image an exposure of 2.0. (Checked in develop module)
9. Change the Exposure of the first image to 1.5, the exposure of the last to 2.5
10. Grid View (G), Metadata->Save Metadata to files
Before saving metadata above, I selected both pictures in Lightroom grid module
*Here you could check, if Lightroom is writing the values to the XMP files properly, by right clicking on the first image, then "Show in Explorer/Finder", and then open the XMP file with the same name as the selected image file in an text editor. Check the value for "Exposure 2012" - if it's 1.5, then LR has written the metadata correctly.
(“Show in Finder” menu was only enabled when righ clicking on the folder and not the image --- no XMP to check with a JPG file)
11. In LRTimelapse: Reload - check the table you should see 1.5 in the Expsure 2012 column for the first image and 2.5 in that column for the last image.

1.5 & 2.5 shows up which did not happen in the earlier test
12. Now apply auto transition
13. Exposure 2012 column should get a linear transition from 1.5 to 2.5. You'll see this in the preview as tilted yellow line too.


I then saved the metadata in LRTimelapse
And in Lightroom, with all 10 files visible, read the metadata into lightroom
I checked all files for the exposure change by stepping through each file in develop mode & they all looked like they had the correct exposure data.
Offline
#4 gregm
I then tried the 490 with 6 keyframes. After editing in Lightroom and saving the Metadata, I could not "reload" the data into LRTimelapse
The Lightroom CC catalogue with these photos are in dropbox
https://www.dropbox.com/sh/elhljya5jfoft...nrv9a?dl=0

I tried the "Reload" button a few times (seen in the following log)
Support request from Greg McCall, , Pyrmont, EMail: emailgregnow@gmail.com
License for: LRTimelapse 3, License type: professional, Payment reference: PayPal, Valid until: Lifetime

[2016-06-08 16:52:46] INFO: Log file was created at /Users/gregmccall/Library/Application Support/LRTimelapse/LRTimelapse.log
[2016-06-08 16:52:46] DEBUG: Loading properties from /Users/gregmccall/Library/Application Support/LRTimelapse/user.props
[2016-06-08 16:52:46] INFO: LRTimelapse 4.6 (2016-03-17) Build 111
[2016-06-08 16:52:46] INFO: © 2016 Gunther Wegner
[2016-06-08 16:52:46] INFO: http://lrtimelapse.com
[2016-06-08 16:52:46] INFO: Java version: 1.8.0_77 (64bit) from Oracle Corporation
[2016-06-08 16:52:46] INFO: Running on: Mac OS X locale: en_US
[2016-06-08 16:52:46] INFO: Found 8 processor cores.
[2016-06-08 16:52:46] INFO: Java runtime: 64 bit
[2016-06-08 16:52:46] INFO: ------------------------------------
[2016-06-08 16:52:47] INFO: Licensed to: Greg McCall, , Pyrmont - Professional License.
[2016-06-08 16:52:47] DEBUG: Initializing directory chooser.
[2016-06-08 16:52:48] INFO: Done (dirchooser)...
[2016-06-08 16:52:48] DEBUG: Launching ExifTool: /usr/local/bin/exiftool
[2016-06-08 16:52:49] INFO: ExifTool: 10.13
{ready}
[2016-06-08 16:52:49] DEBUG: Exif Tool available.
[2016-06-08 16:52:49] DEBUG: DNG Converter available.
[2016-06-08 16:52:49] DEBUG: MPEG Encoder available.
[2016-06-08 16:52:49] INFO: Detected Screen size: 2560 x 1440
[2016-06-08 16:52:54] INFO: Latest version: 4.6 (2016-03-17), current Version: 4.6 (2016-03-17)
[2016-06-08 16:53:36] INFO: --- Loading directory: /Volumes/Promise2/Pictures/! Original Photos/2016/2016-05-27/Berrima Timelapse
[2016-06-08 16:53:47] DEBUG: Memory: [max|1820] [used|152] [free|1668]
[2016-06-08 16:53:47] DEBUG: Loading sequence properties from /Volumes/Promise2/Pictures/! Original Photos/2016/2016-05-27/Berrima Timelapse/.lrt/lrtsequence.properties
[2016-06-08 16:53:48] DEBUG: Buffer size for ExifTool: 48
[2016-06-08 16:53:57] DEBUG: Sequence shot in auto mode
[2016-06-08 16:53:57] DEBUG: Timestamp Data complete!
[2016-06-08 16:53:57] DEBUG: Sequence processed with LRT 4.6, Build 111
[2016-06-08 16:54:19] DEBUG: Done loading previews.
[2016-06-08 16:54:19] DEBUG: Memory: [max|1820] [used|198] [free|1622]
[2016-06-08 18:43:22] INFO: 489 XMP-files successfully saved.
[2016-06-08 19:20:49] INFO: Reloading XMP only...
[2016-06-08 19:20:49] DEBUG: Timestamp Data complete!
[2016-06-08 19:20:52] DEBUG: Buffer size for ExifTool: 48
[2016-06-08 19:20:52] DEBUG: Sequence shot in auto mode
[2016-06-08 19:21:11] INFO: Reloading XMP only...
[2016-06-08 19:21:11] DEBUG: Timestamp Data complete!
[2016-06-08 19:21:13] DEBUG: Buffer size for ExifTool: 48
[2016-06-08 19:21:13] DEBUG: Sequence shot in auto mode
[2016-06-08 19:21:14] DEBUG: Checking and fixing XMP values
[2016-06-08 19:21:19] DEBUG: Calculating Auto Transitions
[2016-06-08 19:27:17] INFO: Reloading XMP only...
[2016-06-08 19:27:17] DEBUG: Timestamp Data complete!
[2016-06-08 19:27:22] DEBUG: Buffer size for ExifTool: 48
[2016-06-08 19:27:22] DEBUG: Sequence shot in auto mode
Offline
#5 gwegner
Log file looks normal. What do you mean with you "couldn't reload" ?
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#6 gregm
When I finished the keyframe edit in lightroom & saved the metadata, back in LRTimelapse, I clicked on the "Reload" button in the second line of the visual workflow to bring the metadata back in LRTimelapse and nothing changed.
Offline
#7 gwegner
When saving metadata in Lightroom before, make sure to be in Grid View (G) and have all images selected. Otherwise LR might only save the metadata for one image.

After hitting "Reload" in LRT, the previews won't instantly change (they will stay the original previews unless you activate "visual previews") but you should see changes in the table, if you scroll to the right. You might try to remove the checkbox on "hide equal columns" and check the values.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#8 gregm
As I have JPGs, it complains when I try to turn visual previews on
I was in Grid view. I think in the first attempt, I had all 6 keyframes in view and selected before saving. This time, I had all photos in the grid view and selected (command A ) and metadata saved.
Still, when back in LRTimelapse, click the Reload button in the Basic Workflow tab, I get the blue bar across the top of the screen indicating it's doing something, but all the columns in the main part of the screen don't seem to change (and all exposure stay at zero).
If I uncheck the "Hide unchanged columns" box, to show all those extra columns, all the data seems the same. Even when I scroll down to the key frame (blue dot) lines
One slight change on the last test is that I updated lightroom this morning to 2015.6 but that seems to have made no difference
I also just went and clicked on a folder of an earlier timelapse with 469 RAW files and that seemed to load the metadata in OK and changed columns were displayed
I reselect the problem folder and all exposures are zero with no difference in the keyframes files compared to the other files
BTW, I have a high end iMac so things usually happen quickly if they are going to happen (4 GHz i7, 32 Gig RAM & 1TB SSD)
Offline
#9 gwegner
You are right - JPGs don't support visual previews.

Maybe the jpgs are read only and the metadata cannot be written to the files? Currently I have no real idea why it works for you with RAW files and not with jpgs.
If I understood your correctly, you made a trial with a subset of the images following my advices from the faq and that worked. But it seems not to work with the full sequence. So maybe one or more of those files from the full set might be corrupt and generating an error? Maybe you can try to narrow that down.
You should check the log file for errors after reloading and applying the auto transition.
Check out my e-book Time Lapse Shooting and Processing!
Subscribe to the LRTimelapse Newsletter!

lrtimelapse.com - advanced Time Lapse Photography made easy!
gwegner.de - Fotografie, Zeitraffer, Video, Reisen.
facebook · Google+ · twitter · vimeo
Offline
#10 gregm
I could not see any errors. Perhaps you could see it for yourself is you look at the files in Dropbox?
https://www.dropbox.com/sh/ldvuwsi2g3tn6...j-xra?dl=0
This dropbox folder has the original folder tree for the timelapse files as well as the lightroom catalogue

...also check out: